New Preview List in the Library Panel

edited October 2019 in General
You can drag from the list onto schematics.

Click to enlarge

image
The developer of AutoTRAX DEX. 
·

Comments

  • edited October 2019
    Hi Iliya!
    The idea is good but I would like to OFF it . Other problem , my computer became slow and I have to wait 10-20 sec and after I get preview function.
    ·
  • edited October 2019
    As Always with DEX, things are optional.

    Don't  want it: don't use it :)


    image


    image
    The developer of AutoTRAX DEX. 
    ·
  • And of course you can also show it.


    image


    image
    The developer of AutoTRAX DEX. 
    ·
  • edited December 2019
    Hi Iliya!
    It is wery good idea but unusable  because my computer bacame slowly and I have to waiting 1-2 minute!
    I would like to OFF this function. Please add one on/off function button.  I can not to off this preview function because  run in the backround. 
    ·
  • Move separator to right.
    The developer of AutoTRAX DEX. 
    ·
  • I try but not happening nothing. I have to close the library panel but after I would like to use library panel I have to wait many times. 
    ·
  • I know what is the problem. 
    The picture show you : 
    image
    ·
  • It might show you something, but I don't see it. I can't read Hungarian.
    The developer of AutoTRAX DEX. 
    ·
  • edited December 2019
    Sorry!
    I have 308  parts and 28,5Mb  in the DEX library.
    ·
  • I have 47,440 parts in 742 folders.

    imageimage
    The developer of AutoTRAX DEX. 
    ·
  • image
    The developer of AutoTRAX DEX. 
    ·
  • edited December 2019
    If you pull the separator over to the right, the icon viewer does absolutely nothing. 


    The developer of AutoTRAX DEX. 
    ·
  • I think do you  use super PC. My PC benchmark olways write DEX eat the highest memory and use Highest energy.
    ·
  • DEX startup time 5 seconds from double clicking on desktop icon to this:


    image
    The developer of AutoTRAX DEX. 
    ·
  • My computer startup time 28 sec without Parts library .With parts library 1-2 minute.
    ·



  • kjocoka said:
    My computer startup time 28 sec without Parts library .With parts library 1-2 minute.
    Do you mean DEX startup time?

    I think it's nothing to do with preview section.

    What type of hard drive do you have?

    The developer of AutoTRAX DEX. 
    ·
  • Yes,DEX startup  time without Parts library 28 sec. After I would like to use Parts library then I can not to work 1-2 minute.  
    I use Kingston SSD drive. 8GB DDR3 Ram and 2x24000MHz processor and internal video card with 23" HDMI monitor. The my computer became too slow after you build the preview function. The preview function fantastic idea, but my computer don't like it.
    ·
  • image
    The developer of AutoTRAX DEX. 
    ·
  • OK!
    Now working more faster !
    Thank you !
    ·
  • Well I like it from the very little time I have had to explore the use of this extra pane.

    I am scratching my head a bit as the preview pane does not seem to be synchronised with the 'symbol' pane at the bottom.

    In my case only the first item in the list will be highlighted in the preview pane, when I move down in the list, the preview pane not updated.

    Is that on purpose or will it be synchronised later


    image
    191211-Dex-2019-12-10-local-library.PNG
    932 x 1023 - 143K
    ·
  • Improved preview on the right hand side. (Drag and drop on schematic supported).


    image
    The developer of AutoTRAX DEX. 
    ·
  • Looking forward to testing this tonight (on my work rest from my wife's job list).

    Just came here to see if the .epw file system  can be handled by DEX.  I down loaded an opto coupler FOD3182 from RS components. There was an offer of CAD drawings. Out of interest I downloaded and found it has something to do with SamacSys and another program needed.

    Looking into it tonight.


    ·
  • Very short visit, installed  Dex 2019.12.16 and can confirm 'synchronisation' works fine.  The right view pane now reflects selection in the list in the left pane.


    ·
  • Library view icon enable menu is not in the 2019.12.16 or I not found.image
    ·
  • kjocoka said:
    Library view icon enable menu is not in the 2019.12.16 or I not found.image

    How long does DEX take to statup?
    The developer of AutoTRAX DEX. 
    ·
  • The library start up time 22 sec.
    The new library preview function is not my favorite and I don't like to use. The old library panel is enough for me.
    ·
  • edited December 2019
    Library view icon enable menu is not in the 2019.12.16 or I not found. 

    It's no longer needed.

    The library panel is exactly the same except for the preview. As described above, drag the splitter bar across to the right and you have what you want : no preview.

    Before, you said it took 28 sec without Parts library, now it's 22 sec. Life is good :)

    My computer startup time 28 sec without Parts library .With parts library 1-2 minute.

    The developer of AutoTRAX DEX. 
    ·
  • Yes really faster :)  but  I select one part  from my library , and after select one part from other library I have to wait 10-22sec . If I would like place some parts then I have to wait much . Other problem: the preview vindow is too big. Other problem no highlight with the selected part. I select a part from old library but not see my part, the picture show you what is the problem. Other : I would like to see together Symbol , Package and 3D . I try to make a photo what I would like to see in the DEX.image
    ·
  • Iliya!
    Small improvement and I think everybody will to like.
    What is your opinion? Other opinion? I only select a part and I see symbol, footprint and 3D. 
    image
    ·
  • LIke this:


    image
    The developer of AutoTRAX DEX. 
    ·
  • Yes,  but better idea if part symbols are  under the box. 
    ·
  • edited December 2019
    kjocoka

    """...I select a part from old library but not see my part, the picture show you what is the problem..."""

    I don't think your part is missing.  You have selected the part from the list on the left side, the part is outside the view frame of the total Preview Screen.  The part is not automatically re locating the 'view frame' so the selected part will always have focus in the 'view frame'  (could be handy if you mainly select from left hand side list.

    In my case I like to make the selection of a part from the 'Preview Screen' because I have multiple versions of the same part as I develop the part.  I like to see my Part Symbol that I am going to select so I get the right one.

    When I select my Symbol Part this way the Left hand list will correctly bring the part label/name into focus here. 
    :)
    ·
  • Right click:


    image
    The developer of AutoTRAX DEX. 
    ·
  • Ah, yes, I had seen that option but not tested it on a big folder.  I will attach a picture when 'small' option used in one of my experimental parts folders. I just discovered that the selected focus can bee turned off by clicking in the area outside the icon border, for example bottom left corner.

    It is not a big deal but may be slightly confusing.  In my case if I have the library part listing still showing the selected part but now not showing selection in the preview frame.  Clicking on the part listing selected item will not restore showing associated preview selection.

    If I click on the item directly below in the listing and then go back to the original listing and click, this will restore selection in the preview view.
    ·
  • Errrh, forgot to add picture above.  Here it is, it shows the preview selection before clicking outside icon areas.

    image
    191217-second-monitor-preview-mainly-01.PNG
    1279 x 1022 - 195K
    ·
  • edited December 2019
    Library Panel
    • Faster preview on the right hand side. 
    • New Part Preview layout on the bottom.
    • Improved selection behaviour.
    • Faster startup.

    image
    The developer of AutoTRAX DEX. 
    ·
  • Have had a quick look at the ver 2019.12.17 the behavior looks good.  The 'synchronisation' list/preview is good, reflects both ways depending on your preferred selection method.

    The symbol/footprint/3D model that is good.  :D
    ·
  • Super!
    The startup time 7sec! 
    Professional Library panel .

    ·
  • edited December 2019
    plover said:

    The symbol/footprint/3D model that is good.  :D
    This was done in response to a suggestion from kjocoka - Thanks  :)
    The developer of AutoTRAX DEX. 
    ·
  • Hi Iliya!
    I would like to rotate 3D part in the preview panel. It is possible?
    ·
  • edited December 2019


    The developer of AutoTRAX DEX. 
    ·
  • The Library > Part Viewer > 3D freezes when you select a part with no model or model not properly designed

    ·
  • edited December 2019
    DEX 20.12.20 not sure what is happening, 3D model disappears after some time. I think what may be happening same as above post. In my case first the model stopped 'synchronising' it froze, ie same model for a number of other parts selected in pre-view pane and then the model window went blank.

    DEX 2019.12.17 the same thing happens but on my system it seems to take longer.  The model will freeze at some stage in my experimental part directory and I don't think it will blank. 

    However when I tested using the 7400 series directory it did eventually blank.  Not found a way to recover  yet, except close DEX and start again.
    ·
  • DEX 20.12.21 this is more resilient as I checked out a number of my own parts. I found that I have many parts without a 3D model or it would take tens of seconds to find the model. The lack of a model does not seem to be a problem as after a number of empty model parts when a part with a model is encountered again it will display ok.

    I probably pushed it too far going back to some very early work I was doing on 3D model creation, could not resist testing them.  It failed so I will try to keep away from those and just check the later parts.

    I am happy with the performance, would just wish I could afford more time experimenting.
    ·
  • I sent bug report because my problem is same. 
    ·
  • I have just spent 20 min looking through a lot of my mainly custom parts.  I avoided the real old parts where I was struggling to understand what I was doing.  This time I did not encounter any crash.  Looked like it worked ok.

    In my previous post when the system crashed well and truly there was nothing I could attach.  When i restarted the pc all was well again.

    Next I will try to do some real work and see how it goes.
    ·
  • plover said:
    In my previous post when the system crashed well and truly there was nothing I could attach.  When i restarted the pc all was well again.

    DEX cannot crash your machine. A device driver can.
    OpenGL drivers really can.

    The developer of AutoTRAX DEX. 
    ·
  • edited December 2019
    Not worried about the crash, I don't think it was DEX either.  my above comment just a reminder to myself when I have forgotten.

    The dot/point with Terminal magnet, could not resist making a quick part build.  Part built with short terminal first and then setting a 'zero-length' option in properties.

    DEX 19.12.22 making a new part, to play with

    Made simple part saved it in my local folder, it shows in the part listing but not in the pre-view
    The part not created with the wizard, just as "new part" no footprint or pad association yet, no 3D model
    Refreshing local library, only made the new part show in the Libray, pre-view ignores the part.
    Closing and opening library does not refresh the 'pre-view' [part sill not showing]

    Closing part file and opening a new project, still no preview of the part. (The new project is not used before next step)

    Closing and opening DEX will then open DEX with the 'new-part' displayed and now the preview shows the 'new-part'. 

    Tested your part, the 'zero-length' points fine.  Noticed your 'dot' still shows 'dot' in properties.  How did you get the dot to sit on the Terminal Magnet boundary?  [ I had to change to 'zero-length in properties]

    I am guessing I started building the part wrongly, somehow should have been able to add the dot length directly.


    Added later:
    Just had a quick look, I understand.  I overlooked the option to set the 'dot' position to 'zero-length'
    All is well. 

    Really looking forward to using this again.
    ·
  • Dex 2019.12.29
    Experimented with 'dot' and 'point' on the terminal magnet. I was a bit slow to notice that the 'point' straddles the terminal magnet outline and the 'dot' only touches. 

    Editing a part in schematic and saving it back to library as new part. This requires Refreshing of library list and the new part shows.  The new part however will not show in the pre-view until DEX is closed and restarted.

    I was mirroring my part and find that 'mirroring vertical' on my machine seems to 'mirror horizontal'. Is meant to be like that?  The icons seem to depict this is back to front.
    ·
  • "I was mirroring my part and find that 'mirroring vertical' on my machine seems to 'mirror horizontal'. Is meant to be like that?  The icons seem to depict this is back to front."
    It is interest idea in the Dex.
    ·
  • Hi Iliya, some parts do not show properly in the Library > Part Viewer > 3D box
    They do not center to the box or the size is not proportionate
    Attached are some part examples having the problems
    Do you think that the parts require re-design?
    When the parts are open with DEX as a Part Editor they show OK
    7z
    7z
    Parts with 3D Problem.7z
    1M
    ·
  • edited December 2019
    This is a snapshot showing the Part Viewer problem as previous post

    I cannot see the posted image (???)






    ·
  • Ca you please add as a zip file?

    Thanks.
    The developer of AutoTRAX DEX. 
    ·
  • Attached file
    image
    7z
    7z
    Parts with 3D Problem.7z
    1M
    ·
  • Sorry now attached as a zip file
    zip
    zip
    Parts with 3D Problem.zip
    1M
    ·
  • Fixed.

    image
    The developer of AutoTRAX DEX. 
    ·
  • edited December 2019

    ·
  • edited December 2019
    Hi Iliya!
    Small improvement need if it is possible in the preview panel. The fist picture show you what is the original preview, and next picture show you what I would like.
    image

    and it is what would like to see when I select one part:

    imageimage
    ·
  • Sorry double picture 
    ·
  • Thanks Iliya!
    Now all the parts show the 3D model centered and properly sized
    ·
  • edited December 2019
    Hi Henrycarra!

    Please check my created part and I would like see a picture.
    image
    part
    part
    MT3508.part
    31K
    ·
  • image
    The developer of AutoTRAX DEX. 
    ·
  • edited December 2019
    Iliya! 
    Please library preview panel picture . Real , original picture need because I not visible well. It is my original picture: Auto zoom need in the preview panel if it is possible,  and not only  in the 3D because the PCB is too small sometimes.

    image
    ·
  • Hi kjocoka, I open your part and it is Ok, except that you should limit the pcb and courtyard sizes near to the surrounding of the 6 pad smd footprint so the Part Viewer can calculate and show the 3D preview in a normal size
    Regards Henry
    ·
  • Thank You!

    ·
  • henrycarra
    I was seeing the same problem of a very small footprint view. I edited the part to resize the PCB in the footprint view but that did not solve the problem. The footprint PCB is now close to the size of the footprint but the preview view is still very small.
    ·
  • Try latest.
    The developer of AutoTRAX DEX. 
    ·
  • I try latest version. Now better but there are some parts and no 3D. In the editor show me all is ok, but library preview is not show 3D. Here a part. Please check it what is wrong in my part.
    part
    part
    TACT 2PIN.part
    302K
    ·
  • Other part: I modify but 3D is not visible normally in the preview .
    part
    part
    MT3508.part
    31K
    ·
  • I not modify this part. Please check it too.
    part
    part
    inductor 5x5mm SMRH4D28-22uH .part
    186K
    ·
  • Please try latest.
    The developer of AutoTRAX DEX. 
    ·
  • Iliya:
    It works perfectly.

    ·
  • edited December 2019
    Better but not good. I use latest version,  2019.12.35.
    Here picture: the problem is same , no 3D picture in the preview window. The part editor show me 3D . I think preview is good but all  problem cause the part editor. I don't know what are wrong my created parts. Please analyze my created parts.I think this cause other 3D problems too.
    image
    part
    part
    PC817-OPTO.part
    92K
    ·
  • Oh ! I think what is wrong in the  part editor. Please open my created part in the part editor. Select PCB and after enable Top package . Now you see the Pcb Border is too big. I think this cause many 3D problems. I check older parts and problems are same : too big Pcb Border.  

    image
    ·
  • Fixed. Note: PCB not shown so PCB size does not matter.

    image
    The developer of AutoTRAX DEX. 
    ·
  • I'm not sure why you use an imported SOIC.

    Imported 3D.

    image


    image

    Parametric SOIC


    image


    image

    Notice the solder!


    Imported 3D part size: 31.4K

    Parametric part size : 2.48K   < 8% size of imported 3D parts.

    Parametric part easily changed.
    The developer of AutoTRAX DEX. 
    ·
  • Easily changed:


    image


    image
    The developer of AutoTRAX DEX. 
    ·
  • More:

    image


    image

    Add center pad:

    image
    The developer of AutoTRAX DEX. 
    ·
  • Leadless:
    image


    And of course DIP

    image
    The developer of AutoTRAX DEX. 
    ·
  • Thank You!
    The preview panel  now working well! Nice work!

    ^:)^
    ·
  • I deleted some part with suspicious 3D origin form the left pane and found that the graphic viewer list does not update the change at the same time leaving the deleted part still visible
    ·
  • Good news > the Library > Part Viewer is working so fine that I could restore some parts that I had discarded before because the conflicting 3D models! Now they look amazing (this is using version dex-2019.12.39.exe, latest as 1:50PM Miami Florida time)
    ·
Sign In or Register to comment.