The case of the Disappearing Nets and Routes

I have created a design using a Sub-system architecture approach with separate schematics for sub sections of the design with ports all aggregated at the top-level schematic. The PCB is a basic 2-layer, rectangle board.  And here's the issue: 

The schematic appears to be correct but when I go to the PCB and start manually routing the board certain nets/routes will eventually disappear when I either route a net or try modifying an already routed net.  When this happens I've discovered that if I go back to the top-level schematic, select a net, leave it selected and then go back to the board, all the signals come back, un-routed of courese, but at least they're back anyway.  It's always the same nets that disappear. 

I tried the using the Electra auto router and what's interesting there is that the nets that like to play Houdini on me do not get passed to Electra.  Something's going on with how the nets are created in Autotrax's internal data base like they're there but they're not there.  

I've also tried but was unsuccessful to flatten the design to see if the hierarchical/sub-system approach has issues when using Ports, but I haven't been successful at copying an entire schematic from one page and ppacing it on another or using the Refactoring tool.  Not sure if this is even possible or whether it's just a case of a loose nut between the chair and the keyboard.

Anyone have any suggestions other than to start over?
·

Comments

  • It looks like you have a repeatable process and it is obviously a bug. You should send a problem report to get it fixed.
    ·
  • Bug report sent in a long time ago.  No response.  I've given up on AutoTRAX and moved onto another platform.  I like the AutoTRAX interface just that the program isn't working for me.
    ·
Sign In or Register to comment.